Workspace is too slow or not loading

Problem
Is your workspace or terminal within workspace not loading or is too slow?

Troubleshooting
Do the following steps one by one and if none of them work, kindly escalate it to Crio Team with details of what you tried.

  1. Check your internet speed in fast.com - Is it at least 10 Mbps?

  2. Are you seeing any packet drops? Got your laptop’s terminal and try the following command.

    If on Linux

    ping -c 20 www.google.com

    If on Windows

    ping -n 20 www.google.com

    Do you see packet drops? If so, this may be the problem.

  3. Click on Reset workspace option in the workspace tab and relaunch your workspace. Most likely it should work in 2-3 minutes of time; may require a screen refresh sometimes.

  4. As a last resort, if it still doesn’t work, you can sign out and sign in again and see if workspace starts working - If none of the above steps solve the problem, and step (3) helps, kindly let the Crio Team know that you had to do this to get your workspace. It’s definitely a bug that we want to understand and fix.

If the above didn’t help and you are doing QPrep Approach Pack:

  1. Run du -hs command to see if you have very large files >50 MB in your workspace. If so, remove them. If you are asking for help kindly let us know the output of:
    du -a . | sort -n -r | head -n 10 # Top files by usage
  2. Also check if you have infinite loop in your code which is causing the system to give a feel as if it hung.

And of course, if none of the above works, kindly ping us!