What is <qbox-host> while in ftp <qbox-host> <port>

I am not able understand what qbox-host is

I created this directory as got to know from other question
/usr/share/empty
but when i am trying to connect using ftp command i am getting this error
ftp: /usr/share/empty: Name or service not known

Hey @manmodesanket, this issue will be solved by creating that particular directory.
HINT!

mkdir -p /usr/share/empty

Right i did that but i am getting above mentioned error

But when is use
mkdir -p /usr/share/empty
Getting this error
mkdir: cannot create directory ‘/usr/share/empty’: Permission denied
Instead i used this
mkdir -p ~/usr/share/empty

Hey @manmodesanket,

sudo mkdir -p /usr/share/empty

Hope this helps.

1 Like

Hey i have created the directory
Bur getting this error when trying to connect using ftp command
ftp: /usr/share/empty: Name or service not known

Have made necessary changes in the conf file.
Hint: passive_lock, anon_user, shared_folder, etc.

Kindly attach some SS.

Oh! @manmodesanket, you are doing wrong.
I think you interpreted ftp wrongly.
Here qbox-host is the host IP address. In this case its your Workspace IP which you will find under Workspace tab in the Crio.Do portal.

HINT: insert your crio IP instead of “192.168.0.1”

ftp -p 192.168.0.1 8081

If this solve the issue then mark and close this topic.

Getting this error now
ftp: connect: Connection timed out
Do we have to add extra variables after port number and root_launch_user in conf file

Hey @manmodesanket, what could be your hypothesis for this issue “Time out”?
Might be the server is not listening or server not running. Think!

Does this mean server is running


the status i am getting using netstat is
tcp 0 0 0.0.0.0:8081 0.0.0.0:* LISTEN

Correct but try once with

sudo ./vsftpd_v…

[sudo] password for crio-user:
500 OOPS: config file not owned by correct user, or not a file

Follow through this thread.

chown: changing ownership of ‘vsftpd_v1’: Operation not permitted

It worked by using sudo but stuck there only
ftp: connect: Connection timed out

@manmodesanket Try to built some hypothesis.

  1. Why do the operation not permitted?
  2. Do it need root access? HINT!

sudo

all_commands