Vsftpd (Mod 3 Milestone 1)

When I m running vsftpd_v1 vsftpd_v1.conf command it goes in next line with blank and keeps on running endlessly without any error.

If it’s going blank then your server is on. Use another terminal to do the next task!

3 Likes

./vsftpd_v1
bash: ./vsftpd_v1: cannot execute binary file: Exec format error
anyone please tell how to resolve this issue

Use the proper command to run your server, the command is given to you, try to run it as sudo.

is this really true!!
if yes then i am struggling with it from last 1 hour for no reason :dizzy_face: :dizzy_face: :dizzy_face:

as when i do -->
sudo systemctl status vsftpd_v1
it does not even recognises vsftp_v1.service as any service

I added vsftpd_v1 file path in env path variable then
sudo vsftpd_v1 vsftpd_v1.conf
getting sudo: vsftpd_v1: command not found
can you please guide me . how to solve this

What did you give in crio-user password??

username : crio-user
password : #######
which is on launch workspace page

Use sudo ./

Did you change the file permission first and then try to run it as sudo. Cause mine is working fine with the same same command.

I’m also facing the same problem as rishi.

@chandra-kiran_crio sir can you please guide us.

i am also facing same issue please help

first make it executable using command :- chmod +x vsftpd_v1
have you change the port number in vsftpd_v1.conf file to 8081? that is neccesary

there is no field for port number in the .conf file

add line “listen_port=8081” in the file

but there were no such instructions given to add any line in the file?

guys read this post most of your doubts are discussed here 500 OOPS: could not bind listening IPv4 socket?