Vsftpd: cannot locate user specified in 'ftp_username':ftp

Hi there!
Can anyone please help me with this? I am getting an error while connecting the Qbox server with the FTP client in the 2nd Milestone.It says-
500 OOPS: vsftpd: cannot locate user specified in ‘ftp_username’:ftp

i am facing same error

Yeah! Even I tried googling and adding ftp_username but error still persists.

Did you manage to solve it??

No not yet! I am still struggling

@Kushal_Crio_TA @Crio-Admin @ajay-crio
please look into this

Did you manage to debug the error?

Yea it requires some additions in the conf file and i placed it in /etc after changing ownership to root. It gave a couple of errors after that but the soln for those are there in the forum itself

Is your issue resolved?

Yes! It is now resolved and I have completed all milestones but I am getting build failure. I checked log file there it says-
INFO Failure: Could not find the entries to confirm that server is listening in file
File: confirm_server_listening.py TEST CASE FAILURE
Kindly help me with this I’m stuck here only. All other cases are passed

How you resolved your issue?
Also I am not able to see vsftpd.log file in workspace even after making change in vsftpd_v1.conf file…

specify user in vsftpd.conf file. Issue gets resolved

I am also not able to locate log file in workspace directory. How to resolve that?

how did you resolved this issue ?

Mention user in the vsftpd_v1.conf file as ftp_username=


already mentioned in .conf file

Is the parameter anonymous user Yes? If so change it no

changed but no result

do I assign the workspace url to ftp_username=?

No crio-user would be assigned to the ftp_username

1 Like