Unable to create a ssl certificate and key


can anyone help me figure out the problem?

Search for configuring openssl with vsftpd, you will find your mistake you are making in creation of certificate.

Check this out! Hope this helps! :slight_smile:
https://www.tecmint.com/secure-vsftpd-using-ssl-tls-on-centos/

hey @Midhun
why this is coming.

it becz the vsftpd binary provided to you doesn’t support tls 1.2
you may comment it as it is not required

1 Like

yes it is resolved but now i am getting
500 OOPS: SSL: cannot load RSA certificate
i checked i have permission to execute .pem file

save the key in same directory

Its ssl_tlsv1 not ssl_tlsv1_2. :slightly_smiling_face:

1 Like


see i am using the same command but i am not getting any certification file.
i have used absolute address also just to be sure

yes @Midhun i have figured that out. thank you. can you look into my latest post please

Hey anmol! Did you specify the directory in config file? Is it the same? Did you try running openssl using sudo or in su - terminal to resolve this issue? Let me know if these questions help🙂

@Midhun
these steps are afterwards, right, i tried running with sudo,still after doing ls in the respective directory i am getting only .key file but no .cert file?
as can be seen in the pic

Anmol its not necessary to put the key in same directory as i didn’t put it and it still worked. Try going through this: https://www.tecmint.com/secure-vsftpd-using-ssl-tls-on-centos/
Check what param is wrong. Since this helped me it will help you too. :slightly_smiling_face:

@Midhun
i have referred this link only ,also i have entered the absolute path of crt and key in .conf file, the problem i am facing is even afer running the command ,my .crt file is not creating anywhere.
hence while running my server its showing RSA certificate can’t be loaded

@Midhun I already did what you said and able to create certificate and key. But after that when I ran vsftpd again then I got an error. And I tried to create a new one but that also give the same as anmol specified.

@Soumyadip
hey you getting .crt file in ls command?

@anmol1point0 No I do not get

@Soumyadip
how do you know then that you are able to create the certificate?

this might help

previously I created that but not under workspace directory and after auto refresh they are gone.