Unable to change FTP Port

In vvftpd_v1.conf file, even after setting listen_port=8081 and restarting the server by executing ./vsftpd_v1 I am getting that FTP is still running on default port 21 instead of 8081. Any hint on how I can resolve this?

Services can be started or stopped only by some privileged account. Plus its only a service. It needs some argument as well for parameter configuration.

There were some additional lines supposed to be copied into .conf file which I already did.
Do you mean I have to add some extra lines along with changing “listen_port” to make it work?

Change ownership of files as services as well. And no extra lines are needed. You just need to make the command work properly

Hey,
There could be 2 possible issues to this problem :

  1. You are not providing proper arguments while opening the FTP Server (if you just provide the IP address without the port, FTP assumes it to be Port 21).
  2. A previous version of Vsftpd server exists, please kill it , you can see this process by typing ps -ef in the terminal. Then restart the Server.

I did the following steps.

  1. change listen_port to 8081 in vsftpd_v1.conf file
  2. The default owner (crio-user) of “vsftpd_v1” and vsftpd_v1.conf was changed to root.
  3. 8081 port was opened to allow incoming connections with - sudo ufw enable; sudo ufw allow 8081
  4. Restarted the server with command with root privileges ./vsftpd_v1

Still, I’m seeing FTP is listening on PORT 21.
Also, ftp 8081 command is giving me “connection refused”.

Have you specified the port separately along with the IP?

Yes, terminal command was "ftp ip_address_of_workspace 8081 which was showing connection refused. It may be because server still listening to 21.
But, the real problem beforehand is being unable to change port number. After all the steps mentioned, after starting server
“sudo lsof -i -P -n | grep LISTEN” command showing that server stil listening to port 21

Can you please check the Instructions and references again, you are probably missing something out

Did u resolve the problem? I am also getting FTP is running on port 21

Thank you so so much. I checked instructions very very carefully and found out I missed “something” out.

Where is the problem ? i can’nt find it

For I didn’t set ownership of conf file to root and I was also running the server in the wrong way.
Check the instructions carefully. The right command to run the server right way was written there.

But i set the ownership of conf file to root and i am running the server by sudo ./vsftpd_v1

Yes, and you’re running the server wrong way. Check the instructions carefully. The correct command is mentioned there.