Test case failed on confirm client server communication (2nd Case)

This is the 6th build failure I’m facing on this module. Every time on the 2nd case.
I checked the log file for every file transfer I did and it had all the entries. I copied the log file to the client_server directory as mentioned in the module but still got build failure.

Someone please look into my case and help me out.

This the error in my lastest submission.

Screenshot from 2020-02-02 22-46-16

I am getting same issue.

Assessing confirm_client_server_communication.py
2020-02-02 17:26:55,531 unitTesting INFO Failure: Local Client hasn’t successfully connected to Server
2020-02-02 17:26:55,535 unitTesting INFO File: confirm_client_server_communication.py | Status: TEST_STATUS_FAILURE

Have you copied your .log file after uploading/downloading the files from client to QBox server and vice versa??? both upload and download are necessary from Desktop or mobile client.

2 Likes

yes I did it but this case is for local_server_client not for external_server_clietn

I uploaded files from my desktop and mobile phone to server and downloaded files from server on my desktop and mobile phone. After that I copied the .log file to client_server directory.
Is this what you’re asking?

Yes… and same for upload.txt and download.txt!!!.. try changing permission of .log file

Thanks for helping,
It will work for me I missed to copy log file of local_client.

wait! what do you mean by upload.txt and download.txt?

in milestone 2 of module 3 you have to do this and copy your log file

I guess this could be the issue. After so many build failures in the 3rd milestone, I totally forgot about the 2nd one. Hopefully this time it’ll work. Thanks!!!

Also guys see the failure message:
It’s talking about “Local Client”
if you get the hint then you will succeed the test case. I failed to notice this and suffered a bit.
If it still not resolved, reply.

It is still not solved. Please help

execute your vsftpd
and do a netstat
see the ip address before the port 8081 ?
that is a local ip
use that to do ftp
then upload and download.

For Milestone Task #2 Connect to QBox Server using the local client

  1. Go to the ftp_client directory.
  2. Run ftp <localhost> 8081 from the ftp_client directory to connect to the QBox server.
  3. Transfer upload.txt from the client to the server using the put command.
  4. Transfer download.txt from the server to the client using the get command.
  5. Close the ftp connection.

HINT!

ftp -p 0.0.0.0 8081

1 Like

hey rutviz,
i am facing not connected error in both local and external
ps:I have used 0.0.0.0 8081 for both ftp_client and ftp_server and upload and download files and both are getting transferred.
also i have used 2 mobile clients, (hope it isn’t any problem) i am able to transfer all files to both files and can download it.
also i have copied my log file in the last,pushed my code to repo and then still the same error.
please help its too confusing now.
here’s the ss of my log file

  1. The local client task and external client task requires you to ftp on different ip address.
  2. The file you transfer, is it going to the correct location ? (uploading a file -> it should go to ftp_server) and so on.
  3. Are you sure that correct file is transfered ? ie have you opened the file or did checksum ? because even if file is not transfered it will create an empty file of that name.

hey rutviz,
1.i am doing 0.0.0.0 8081 for local ftp and workspace ip for mobile clients.(when i am uploading file through mobile client on QBox server it is showing when i am doing ls command while connecting locally.
2. yes it is transferring to correct location, i have opened a file using cat and it is correct
3.yes correct file is tranferred, i am transferring .jpg file to QBox through my mobile clients and it is showing when i am connecting locally.
where can i possoble go wrong?

1 Like

See the log file. Is everything is being logged properly ?
keep the vsftpd.log open and do download and upload to check whether its being logged or not.
do send a screenshot of it after you do this step.

whe i use put command in ftp_client , it says : local: upload.txt: No such file or directory

whe i use put command in ftp_client , it says : local: upload.txt: No such file or directory