Test case confirm_server_listening failed

My QBox is working I connected from desktop , phone and also got the files.
but the test case confirm server listening is not passing ?
what should I do about it ?

Hey, can you please check the TODO’s and work accordingly?

I don’t know what to look at.
My netstat is showing the server is listening at 8081

I have made the executable and conf to be owner as root
then sudo exe conf to run it.

I am able to login through terminal to do ftp and also through filezilla, andFTP.

If my server weren’t listening then I would not be able to exchange files too I think but that is not the case, I am able to upload and download files too.

@Rahul-Crio.do could you point me in a direction of where to look for the error.

I have checked and am sure that i have followed the TODOs mentioned.

even after making changes is there a way i can confirm from the log files that my server is indeed listening or do I just git push and pray :sweat:

Please check if the output you are redirecting to the submission file shows your server listening on the intended port.

does this not mean my server is listening at port 8081

I tried to grep the word listen that returned no results.

Could be, but when you do the netstat -an command that is suggested, what do you see?

image

I see the server running at 8081 and my 8082 and 8083 occupied by clients.

@Kiran did you mean this command.

netstat -an | tee ~/workspace/anugrahsinghal1-ME_QBOX/client_server/server_connections

I ran it very early on.

are we checking this file to confirm that server is indeed listening ??

Yes, this file gets checked.

I am also able to connect to clients and my server is also but still my test case confirm_server_listening is failing. Please help @Rahul-Crio.do @Kiran
Here is my netstat command output
image

Please check if the server_connections file that you have submitted also shows this.

It worked!!
Thanks @Kiran

Can you help me out , i am also facing same issuse for 4-5 days

where is this file ma’am

Please follow instructions. This file needs to be created as detailed in the milestone.

I have gone through all the milestones their is no information about server_connections file.
@chandra-kiran_crio

I have gone through all the milestones their is no information about server_connections file.

Please go through them again. You should see this in the milestones -
netstat -an | tee ~/workspace/<username>-ME_QBOX/client_server/server_connections

ma’am I have successfully uploaded and downloaded the file but there is no entry in the vsft log file