Tcpdump command in milestone 3 of module 6

when I use
sudo tcpdump -C 2 port not 8080 -w secure_file_transfer.pcap
file transfer gets queued and

to capture the packet the above command cretes too many file like
secure_file_transfer.pcap

secure_file_transfer1.pcap
secure_file_transfer2.pcap

and soon

i am using port not 8080 in tcpdump but still this issue is not resolved

I dont think you need to use -C command and specify which interface to use

Hey tijira! When you use -C option in tcpdump you specify the maximum filesize of pcap file. So once the size is reached it creates another pcap file and this cycle continues until you have captured the packets. So -C is the problem here.

Read this for in-detail explanation: https://www.tcpdump.org/manpages/tcpdump.1.html

I Hope this helps. :slightly_smiling_face:

if -C is not specified the file size exceeds 2 mb size

1 Like