Sudo password == workspace password?

Is sudo access password not the same as crio workspace password. If not, then is it needed to run vsftpd_v1 or there’s some other way to run it .

Yes both the passwords are same. Make sure you are copying the password correctly without whitespaces. Try typing the password manually and it should work.

I’ve been typing, copying and doing all sorts of other things for an hour now. It’s not working ;(

you dont need to run it as root focus on run_as_launching_user find your solution around this.

I tried setting run_as_launching_user=YES in the vsftpd_v1.conf, but it didn’t work.
I tried changing the $PATH, but ended up with the 500 OOPS error.

use ./ to run dont use direct command.

Still the same error;(

It did worked and I made some progress. Thanks @hj1509 and @shardul08.

1 Like

I set listen to YES
run_as_launching_user to YES
Then trying to run it using ./
But it is giving me
500 OOPS: could not bind listening IPv4 socket

Could you help me

use “ps -ef | grep vsftpd” to check if server is already running.
If it’s running use “sudo kill pid” where pid is the number in the 2nd column.

crio-user@mr-someshdave:~/workspace/QBox$ ps -ef|grep vsftpd
crio-us+ 6012 5986 0 10:09 pts/0 00:00:00 grep --color=auto vsftpd
crio-user@mr-someshdave:~/workspace/QBox$ sudo kill 5986
[sudo] password for crio-user:
crio-user@mr-someshdave:~/workspace/QBox$ ps -ef|grep vsftpd
crio-us+ 6016 5986 0 10:09 pts/0 00:00:00 grep --color=auto vsftpd
crio-user@mr-someshdave:~/workspace/QBox$ sudo kill 6016
kill: (6016): No such process
crio-user@mr-someshdave:~/workspace/QBox$

It’s not killing

can you send the command you are using to connect to server (the one after which gave the error 500 OOPS error)

This time it did not give me an error but a cursor less screen appeared and after I exited it using Ctrl C and entered ps -ef|grep vsftpd I got this
crio-us+ 6154 5986 0 10:18 pts/0 00:00:00 grep --color=auto vsftpd

Am I in the correct

Without setting listen_port = 8081
I am getting
500 OOPS: could not bind listening IPv4 socket
After setting port to 8081
I get blank screen without cursor

The command used is ./vsftpd_v1 vsftpd_v1.conf

Blank screen without cursor indicates that your server is running.
Open a new terminal and then proceed.


is this okay

first kill the process
then set port to 8081 if not already set
then use this ./vsftpd_v1 vsftpd_v1.conf


its not getting killed what to do

you’re using the wrong pid
try : sudo kill 6386


do i kill 6554 also?