Setup Can't complete multiple things can't be initialised

{“message”:“cannot initialize module TreeWalker - cannot initialize module FileContentsHolder - Unable to instantiate ‘FileContentsHolder’ class, it is also not possible to instantiate it as .FileContentsHolder, FileContentsHolderCheck, .FileContentsHolderCheck. Please recheck that class name is specified as canonical name or read how to configure short name usage https://checkstyle.org/config.html#Packages. Please also recheck that provided ClassLoader to Checker is configured correctly.”}

@ved, you can ignore these errors. That’s what I did. It won’t affect what you’re supposed to do.

Just ignore this message and carry on. It wouldn’t affect your project.

@ankushshetkar16 My debugger isn’t working when i run it shows failed but breakpoints doesn’t appear nor the floating window to jump to next statement continue

@ved Remove the first breakpoint. There’s nothing on the first breakpoint line.

@shoryajain Help me out with setup . qmoney > src > main > java > com > crio > warmup > stock > PortfolioManagerApplication.java
I set breakpoint at 47 as red dot in ide

Went to Debugging section
Main Read File > RunTest

If the line having breakpoint is inside the method and isn’t empty. you shouldn’t have a problem.

@ankushshetkar16 How can i realise setup is complete . I am not getting floating window for next statement, continue and s

top

@shoryajain It’s inside method and i have use debugger before it stop makes that line highlighted
also floating window appear for continue , next and all
but i am not getting it

From your first screenshot, there is a breakpoint on line 47 which is empty, If its still there, just remove it and retain only one for line 48. Then try again.

Also, I can’t grasp where exactly you are having trouble here, if you could explain a little bit?

1 Like

I am unable to use breakpoint functionality as my execution just finishes and shows out failed
instead desired output is excution stop at breakpoint and ask me to go either line by line or continue till next breakpoint.

Nor i am getting variable and all

@ved In module 1 Setup #2 follow the instructions for debugging and see if you’re doing it right. You’re running the test. But for breakpoints you have to select debug test.

You are right in your understanding of desired output.

Do one thing, remove all breakpoints first. All of them. Then just add one on return statement of mainReadFile. And then run a debug test. Let me know if that works!

Finally , it worked for me. I don’t know if its VM error or something from my side.
It starts to break at breakpoints and giving out.

I reloaded the window using pallete .