QBox Module 3, Milestone # 1

Running my vsftpd_v1 gives 500 OOPS: vsftpd: must be started as root (see run_as_launching_user option) this error, but when I run sudo su the I run vsftpd_v1 command it says command not found?
I have added the PATH again but the same problem persists.

@AkhzarFarhan You don’t need sudo su. Go to the QBox directory and run it like so:

sudo ./vsftpd_v1 vsftpd.conf

I tried running the mention command using sudo but i get the following error:
500 OOPS: config file not owned by correct user, or not a file

did u get that how to resolve this error

This error shows that the file is not owned by the user who is trying to run it (here it is root, because the command is being run using sudo at the begenning)

You have to use chown command to resolve the issue.
Make root as the file owner.

e.g., sudo chown root ~/workspace/crio-user/YOUR-WORKSPACE-NAME/filename.conf

1 Like

If your error is something related to ownership of file then use following command by editing it.
sudo chown root ~/workspace/crio-user/YOUR-WORKSPACE-NAME/filename.conf

1 Like