[QBox][MODULE 3]: Cannot connect ftp server from desktop and mobile clients


I have been successfully able to connect and transfer files from the crio workspace terminal but I am not able to establish a connection from Filezilla and AndFTP clients.

Also, I have gone through all the posts related to this issue in the forum but could not find a working solution.

Solutions I have tried:

  1. Verified that I am connecting to the Crio workspace IP address and 8081 port
  2. vsftpd.conf file has all the parameters set correctly as mentioned in the forum posts
  3. I have tried switching my network from Wi-Fi to mobile network hotspot
  4. I have verified that I am entering the correct username and password

After having done the above steps, I am still not able to establish a connection

On the Filezilla client, the console looks like:

On my AndFTP client, the console looks like:

Today is the final day for completing this module and I need your help to get through this module.
–help -please

Also, please help me in understanding what should I fill in the remote-directory field while trying to connect from AndFTP.

Thanks and Regards,
Praveen Sunkara

Hi @praveen.sunkara
Looks like you are facing challenges in the current module.

Below is a link to all the FAQ’s for the current module

Below are a few similar topics raised by other users which you might find usefull

Note - This is a BETA Feature,if you find this helpful, kindly let us know.
Feedback link - https://forms.gle/cmxN5pdTXgnwgC986

Kindly mark this as a solution if this has helped you solve your query

Below is the screen capture of the netstat -an output from the online IDE

I see that the ip address is already connected to port 8080, do I need to kill this process and then try connecting from FileZilla and AndFTP?

Hi @praveen.sunkara,

Please try resetting your workspace so that all connections are rest and then start the vsftpd server. Also, I’ll recommend restarting Filezilla as it has been known to cause connection issues sometimes.

Hey Shorya,
What is the ideal way of resetting the workspace?
I have seen that just closing the browser doesn’t reset the workspace.

Hi @praveen.sunkara,

Can you please verify you are using the public IP of your workspace?

Closing this topic as your issue is resolved by the mentor. If it is still not resolved, Kindly un-mark the accepted solution or create a new topic and post this question as a reference link in the description of the new topic.