Put command not working

When I use the put command for upload.txt from ftp_client directory, how to transfer it to the ftp_server
directory?

Once you see ftp command line. E.g. ftp>
You just need to type put <file_name>
This will automatically upload the file. Read the ftp docs for more info on this.

See the server directory and make changes to it accordingly.
All the required commands already introduced in the task tab.
You can also look for ftp command to change directories in google.

Yes, it upload the file on ftp server , but how to transfer it to ftp_server directory?

Absolute path is needed.

but where to specify this absolute path? In the put command ?
Like this - put upload.txt /home/crio-user/workspace/ftp_server/

Is this worked for you?? It says-
200 PORT command successful. Consider using PASV.
553 Could not create file.
Can you help me with this?? I also tried changing permissions

and then have you used “pass” command?

No! I haven’t done it yet

yeah. just use pass command… then use put command with path to file

Pass command ? Do you mean entering passive mode? Please let me know about references to learn using it

It worked even without using it. Btw thankyou for helping :slightly_smiling_face:

have you solved it, i am also facing the same issue

how did you do it? I am facing the same issue

1 Like

Try using put command with absolute path for both local and remote clients and changing name of uploaded file.

1 Like


tried doing with all the above mentioned ways then also I am getting error any suggestion
@sammynerd @ndsingh @AmoghaKS

Is your ftp_client and ftp _server directories empty? Have you used the cat command that was mentioned in the task.

yes I have used those commands , but than also the folders were empty

Should I add those txt filles manually @AmoghaKS

It can’t be empty. In your workspace under ftp_client and ftp_server directories you must have upload and download files respectively.