Permission denied when using get

i am creating 1gb file outside workspace also i am connecting ftp outside my workspace because inside workspace it is getting stuck during file transfer.
problem is i am able to use put file.txt and it is getting uploaded but when i am doing get file.txt it is showing permission denied.
any help?

Hey, its possible that the file permission/size has been changed. Check again.

thank you sir, i found out the solution, actually file ownership was the issue.

My file owner and the owner which I used for ftp login are same, still getting the same error

are you able to login?

Yes
and also solved the problem, thanks for ur reply

plz help me out in this

could you please check the permission of upload.txt file if it has read permissions then check your conf file.

write_enable? Is this boolean value specified in the vsftpd log file

checked but still not working

i have specified it in vsftpd_v1.conf then also not working

Please provide the ls and !ls screenshots from your terminal. It may be possible that you are in the wrong directory

try using 0.0.0.0 8081

@neha you have to transfer the file from ~/workspace/ftp_client/upload.txt to ~/workspace/ftp_server/

However, here, I think the problem is with your upload.txt’s permissions. You can check using ls -l command. If it shows owner as root user, you’ll need to change the ownership to crio-user

First of all you have to provide the full address of upload.txt file.