Package import error while building the gradle

It shows package doesn’t exist while building Gradle. Please help.

https://docs.oracle.com/javase/7/docs/api/java/lang/Thread.UncaughtExceptionHandler.html
Go onto line 113 put your cursor on that line and do a quick fix. That will import the correct library automatically.

Should I import package com.crio.warmup.stock.log.UncaughtExceptionHandler or java.lang.Thread.UncaughtExceptionHandler? It is giving error on importing any package from other directory(When I was trying to import PortfolioTrade class, it show the same error).

I have done Quick fix which imported com.crio.warmup.stock.log.UncaughtExceptionHandler but again gradle build failed.

Can you please provide us a screenshot ?

I am getting the following errors after ./gradlew build

Task :qmoney:pmdMain
This analysis could be faster, please consider using Incremental Analysis: https://pmd.github.io/pmd-6.10.0/pmd_userdocs_incremental_analysis.html
4 PMD rule violations were found. See the report at: file:///home/crio-user/workspace/adiphisake-ME_QMONEY/qmoney/build/reports/pmd/main.html

Task :qmoney:spotbugsMain FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:qmoney:spotbugsMain’.

SpotBugs rule violations were found. See the report at: file:///home/crio-user/workspace/adiphisake-ME_QMONEY/qmoney/build/reports/spotbugs/main.html

When I run the gradle, I get import error even after quick fix.

Is it a problem with gradle executable? Because running the tests manually in PrortfolioManagerApplicationTest.java gives the desirable result.

Running the tests from test library works, executing the code locally also gives the required result but gradle build fails due to ‘package does not exist’. The gradle build should execute to pass the assessment.

Can you confirm this is their or not in your file - package com.crio.warmup.stock;

Sir, this package is present in the file:

Try running ./gradlew clean and build again