Not getting milestone 3 of module 5

@Kiran @amanagar
i am stuck at finding “internal_to_external_IP_mapping”,
i am connecting my filezilla to the server,then i am doing “netstat -ant| grep 8081”
and same in dos “netstat -ant| findstr 8081”
but i am not getting any port common anywhere, instead i am getting different ports, does it mean there is any imposter, but there is no imposter from my side like proxy or something, i even tried with mobile hotspot, still no luck
any hint?

dont use grep and just find 8081 port in foreign ip provided by netstat -ant on both sides
server side as well as client side

nope still the same error

Running netstat on your machine you can determine all the established connection and inorder to to find which ip corresponds to your workspace in your machine you can always use the port number.

@Kunal
yes i am using grep for that only.
8081 on both sides.

Your output of command is correct
Now run netstat -an on your workspace

@Kunal
the pic contains both, the down one is workspace and upper one is windows prompt

You can record your observation. If you will see the milestone, to do specifies that you have to record the ip shown for your machine in dos and the ip given to your machine by QBox. You can check online about the mapping and how its taking place.

@Kunal
i didn’t get what you said.
can you elaborate?

First line: specify the IP address of the client (seen in the  `netstat`  output on laptop) followed
by the IP address assigned to the client internally on the QBox Server side. Separate the 2 IP addresses by space.

I am not able to get “specify the IP address of the client”. Is it the local address?

yes, it is local address or ipv4 address of the client

guys pls help me with this how to specify packet no i have captured packets what to do after that

packet_numbers_for_tcp_connection_setup

Observe that .pcap in wireshark.
Hint : Look for TCP handshake.

The issue you are having is about an imposter. But if you will look in your DOS output it states your machine has established connection with 3.6.137.210:8081 and doing the same in your workspace shows the connection to a foreign address via 8081. This tells itself that there is no imposter. An established connection is uniquely identified by the combination of client-side and server-side IP/Port pairs. Now if you are thinking why Ip are different well its the purpose of the milestone that you should find out.

@Kunal
yes, i understand that, if you see my topic , i mentioned that there can’t be any imposter from my side at least, and I am trying to figure out this since afternoon,and as muchI have researched about this topic on google , i think this should come this way only.
still can you give me any hint

HINT
How about if you don’t grep for one particular port? Can you find a matching connection in that case?
On your laptop (DOS) you should see a connection established with the IP address of the VM (you know this IP from the workspace). What ports do you see in this established TCP connection?
Try to look for those ports in the netstat output on the QBox Host.

2 Likes

thank you sir,its resolved
i am on module 6 now.

@divs30
Are you sure the entries corresponding to the screenshot of the Crio workspace was taken when the laptop was in connection with the QBox Server?

The connection state will be Established for connected ports. You can see this for the entries of your laptop netstat but not in the latter.

Kindly check that

laptop :


workspace :

thanks for pointing that out , but now I think I am getting IPv6 address , unable to understand what to do @nabhanpv
whenever I am getting right ip on laptop then my workspace port shows listen and when it shows connection established than laptop gives ipv6 or port doesn’t get addressed

is there any problem if address is ipv6 please help out @nabhanpv