Not allowing edit vsftpd_v1.conf

I changed the ownership of vsftpd_v1.conf to run the server.I checked it using ps -ef and netstat,its running.But when I’m trying to add listen_port it is not getting saved,an error is popping up.I changed the ownership to crio-user again to add the listen_port.However I found no listen_port variable in the file.Should I add it ?Also to take a backup of vsftpd_v1.conf should I save it in the backup directory created earlier with crio-user ownership or root ownership?

You can add whatever is required in the config file. And backup is not mandatory.

check the mode of a file using ls -l and see in which mode and for which user you have write permissions. Accordingly proceed further.

If listen_port parameter is not present in the config file, you can add it in the file. You can save the backup in backup directory you created earlier in the previous modules.

1 Like

–> ls -l (This will give the details regarding the the ownership of the file)

  1. If you have used chown command to change the owner to root for vsftpd_v1.conf then if you make a change in it, a pop will arise at the right bottom (cant save the changes: permission denied)
  2. So how do you make changes?
    simply change the ownership to “crio-user”. Then make the required changes.