Not able to pass the testcase 2

I have done everything in module 3 successfully but somehow the log file is not able keep track of the HOST. It is registering the ftp response and commands but not the port information. How to solve this problem?

This is the vsftpd.log file output. ftp connection is running smoothly but HOST: 8081 is not there in this file though the port is 8081 only when checked using netstat command.
Fri Feb 14 20:08:59 2020 [pid 2] CONNECT: Client “”
Fri Feb 14 20:08:59 2020 [pid 2] FTP response: Client “”, “220 (vsFTPd 3.0.3)”
Fri Feb 14 20:09:03 2020 [pid 2] FTP command: Client “”, “USER crio-user”
Fri Feb 14 20:09:03 2020 [pid 2] [crio-user] FTP response: Client “”, “331 Please specify the password.”
Fri Feb 14 20:09:08 2020 [pid 2] [crio-user] FTP command: Client “”, "PASS "
Fri Feb 14 20:09:08 2020 [pid 1] [crio-user] OK LOGIN: Client “”
Fri Feb 14 20:09:08 2020 [pid 3] [crio-user] FTP response: Client “”, “230 Login successful.”
Fri Feb 14 20:09:08 2020 [pid 3] [crio-user] FTP command: Client “”, “SYST”
Fri Feb 14 20:09:08 2020 [pid 3] [crio-user] FTP response: Client “”, “215 UNIX Type: L8”

The port number isn’t logged by default. The vsftpd configuration is limited to the supported commands for vsfttd.conf. There is a log_ftp_protocol(which we are already using) for verbose logging, but I couldn’t find anything regarding changing the formatting of log.

Anyway for the purpose of the milestones, we don’t require this. In milestone 2, we only need to connect to the QBox server and transfer the files mentioned in the milestone

Let me know if it helped :slight_smile:

this is the path defined in the vsftpd.conf file. Using netstat command, I also checked that the 8081 port is listening. What else is missing?

I don’t understand. What error are you getting in the assessment?

2020-02-14 15:44:21,711 unitTesting INFO Assessing
2020-02-14 15:44:21,994 unitTesting INFO Failure: Local Client hasn’t successfully connected to Server

2020-02-14 15:44:22,027 unitTesting INFO File: | Status: TEST_STATUS_FAILURE

Ok, if you are using the workspace ip(public ip) or with the ftp command to connect to the QBox server, please look at this

Yay! It helped. I have successfully pass module 3. Thanks man.

Cool. Please close the topic so that others can also find the solution if they are in trouble.

It solved the problem by using the ip instead of workspace id. The assessments are done but I still don’t understand that why this change was necessary and what difference it made conceptually.

If you try executing the ifconfig command you can see there are more than 1 network adapters. is an alias to all of the ip addresses a m/c points to. So, if your server has let’s 2 ip addresses. We can connect to the server using both of these and can be used for listening to requests coming to either of the ip addresses.

Whereas is the system local loopback address.

For the purpose of the milestone, I tried uploading files using both and got similar entries in vsftpd.log. So, I think technically they could both be used.

can you share some link for the detailed explanation?

This might help