No control connection for command: Transport endpoint is not connected

i m getting this error “No control connection for command: Transport endpoint is not connected”
pls help in module 3

i ran these commands
and pasv_promiscuous=YES in my conf file
sudo ftp 0.0.0.0 8081
[sudo] password for crio-user:
Connected to 0.0.0.0.
220 (vsFTPd 3.0.3)
Name (0.0.0.0:root): crio-user
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> pass
Passive mode on.
ftp> put /home/crio-user/workspace/ftp_client/upload.txt /home/crio-user/workspace/ftp_server
local: /home/crio-user/workspace/ftp_client/upload.txt remote: /home/crio-user/workspace/ftp_server
No control connection for command: Transport endpoint is not connected
Passive mode refused.
ftp>

Hey try to do it without using pass command don’t use pass before transferring files

I have tried without pass , I encounter another error without pass command

Make sure CONNECT_FROM_PORT_20=YES in your config file

this is my conf file

anonymous_enable=NO

ftp_username=crio-user

secure_chroot_dir=/home/crio-user/workspace/usr/share/empty
local_enable=YES

pasv_promiscuous=YES
dirmessage_enable=YES

xferlog_enable=YES

connect_from_port_20=YES
listen=YES

listen_port=8081

vsftpd_log_file=/home/crio-user/workspace/vsftpd.log

xferlog_enable=YES

xferlog_std_format=NO

syslog_enable=NO

log_ftp_protocol=YES

pls help me how to resolve this error?

@addy12
Please share what error you are receiving

Hey @addy12 make write_enable parameter yes and just stick to the instructions and define parameters which are give in the instructions and make sure you are not doin any kind of TYPO mistake into the vsftpd.log file so follow these you will get it done