NO change in cpu usage when i run different versions of vsftpd

the cpu usage remains 0.0% whenever i try to upload 1gb file using put in ftp. Also the file size reduces to zero whenever i try to upload it to the server.

Hey the task is to find considerable changes in the versions of vsftpd, if there is no change in a particular version, move over to the next one, please read and understand the task accordingly.

when you start the ftp, it starts a new child process of the server, so don’t just look into one process by pid, look for every child process cpu usage.

It’s probable that when you transfer the file , it gets overwritten and the size reduces to zero.

but why its taking no time to upload or download? seems like the transfer is taking place in no time. I am facing this error for all the versions of vsftpd.

it’s showing this
image

If the transfer is not taking any time, then the file size is probably zero.
Somewhere the file gets overwritten and reduces to zero.

Ahh thats the issue, use a text file, it will solve the problem :slight_smile:


Checkout the above link

No change.I made a new txt file .and again tried to upload it.Again it gets uploaded in no time with ftp cpu usage =0.

Also the file size has reduced to 0.
image

Try to understand what file you are putting where. If you look closely at what you are doing in the FTP window, you’ll see that you are replacing a file with itself. (Hint: look at the local and remote directories just below the put request you are making.)

1 Like

thanks it worked. :smiley: :smiley: :smiley:

1 Like

Hey while running top command I am not having no user as nobody and even while starting ftp server if I am trying to assign user name as nobody or root I am getting 420 error i.e.
Name (0.0.0.0:crio-user): root
331 Please specify the password.
Password:
500 OOPS: 421 Service not available, remote server has closed connection
Am I doing right although I am getting variable cpu and memeory usage by top command for crio user for vsftpd_v1 file

You do not need to change usernames. Please search in the forums what the username and password for FTP should be, this has been answered many times already.

I know it’s crio user and password is one on my workspace but I am asking if I need to give other user name as root or nobody because in my execution of top command I am nowhere getting nobody as user

Monitor the process. Don’t worry about the users.

I find no where my vsftpd_v1 process in my top command although I have successfully transfered my file from client to server via ftp

and my ftp server


May you tell what wrong I am doing

You need to monitor top as soon as the file starts transferring. Not after it is done.

means in just secs like I saw a process like ftp just glimpse with cpu %13.9 but than it disappeared , so do I have to look for ftp name process or vsftpd_v1 process

Which process is to be monitored has been asked several times in the forum. Try to figure it out yourself or search in the forums. If you want more time to monitor, maybe consider transferring a bigger file, like 2GB or 3GB.