Module - 4 File Permission Problem

I have a problem with the file permission module. All the versions are resulting in the same file permission for the uploaded file.

I also want to inform that I have created a different file each time.

Hi. You should always remove the file from server folder before trying new versions. File retains permissions from previous versions if not removed.

1 Like

I did that, I created new files for the same.

Have you yet added any flags to the vsftpd.conf file?

you need to check whether you are getting right permissions ,because in this milestone you have to detect as well as solve the permission problem

I had reverted back to the original flags.

Listen i am gonna tell exactly what you need to do.

  1. Check with each version the file permission of uploaded file is same as the benchmark file or different. If different, report it.
  2. Delete the file in server before checking with new version.
  3. Add flags so that you get same permissions with every version.

Thank you.
My evaluate_file_permission_config_params shows failure. I have tested the params it works fine but test shows failed.

Maybe you are using some other parameters?
Hint - You have to give read and write permissions to user in this task. Check about this permission on google !

See, The permissions are fine.
I am changing file_umask values.


But the config files are not passing the solution.

see if this post helps you

1 Like

by benchmark file you mean file permissions for QBox_benchmark and uploaded file is the one which we create by dd command for each version do we need to match their file permissions

Are you using 3 digit value when you are setting the value for umask? You are working with octal values(?) here, you better prefix it with a ‘0’. So that it is a 4 digit value

You are using file_umask as you said.
Use the umask from this link. That helps I guess.

also be careful with the format you are using for assessment