Module 3 vsftpd.log file empty

my vsftpd.log file is empty after completing the transfer
that is vscode is unable to show the contents of vsftpd.log file

but using sudo vi vsftpd.conf it shows all the details in the terminal

will this create any problem during assessment

  1. is vi without sudo working? tried closing the folder and opening it again in vscode?

yes vi with sudo is working
but when I refreshed the window its still not visible in vsftpd.log

is vi/nano working without sudo? ( it should work )
not refresh, close the folder (vscode workspace) then open it again. (top left, open folder, like you had done initially)
You can also change ownership of files in linux, google that out if required.
Take some time to understand and try to figure out why this is happening.

no vi and nano is not working without
sudo

check the ownership of the file. If it is root, change it to the user. Try opening it again in editor, it will display its contents.

1 Like

i have done it thanx for your reply

is it necessary to change the ownership to pass the module 3 assessment?? @tijira @ssindher11

faced the same issue, the alternative is to just give read permission to all users using the chmod command