Module 3 Test 3 Failed

When Submitting the code for module3 . My 3rd test case fail,is it due to milestone 3 or any other.
this is the log file
2020-02-16 05:45:56,480 unitTesting INFO Running command_runner
2020-02-16 05:45:56,563 unitTesting INFO Running setup.sh…
2020-02-16 05:45:57,234 unitTesting INFO Module setup complete!
2020-02-16 05:45:57,236 unitTesting INFO Starting assessment…
2020-02-16 05:45:57,236 unitTesting INFO Assessing confirm_server_listening.py
2020-02-16 05:45:57,497 unitTesting INFO File: confirm_server_listening.py | Status: TEST_STATUS_SUCCESS
2020-02-16 05:45:57,499 unitTesting INFO Assessing confirm_client_server_communication.py
2020-02-16 05:45:57,900 unitTesting INFO File: confirm_client_server_communication.py | Status: TEST_STATUS_SUCCESS
2020-02-16 05:45:57,902 unitTesting INFO Assessing confirm_external_client_server_communication.py
2020-02-16 05:45:58,297 unitTesting INFO Failure: External Client hasn’t successfully downloaded file to Server

2020-02-16 05:45:58,299 unitTesting INFO File: confirm_external_client_server_communication.py | Status: TEST_STATUS_FAILURE
2020-02-16 05:45:58,299 unitTesting INFO Assessment finished!
2020-02-16 05:45:58,299 unitTesting INFO Starting cleanup…
2020-02-16 05:45:58,356 unitTesting INFO Running cleanup.sh…

Please Help

When connecting to external client using QBox, you need to perform both upload and download of files.

When I am trying to upload file from QBox server to external client ,I am getting this error
failed to open “file location” for writing.File transfer failed
do i need change something in conf file for this error

Please look into this

Thank you It worked successfully

can you help me for second test case
in this we need to connect only with crio credential or any thing else

yes only crio credentials

but still im not getting success please help

I think also you need to transfer , that files upload.txt and download.txt

ok i will try with upload.txt and download.txt file


still not getting any effect

cross check in ftp_client and ftp_server directory that is your transfer successfully completed?

PLease help me regarding this

i fire this command

from ftp_client
ftp url port
then put upload.txt
and then get download.txt

now anythin is left?

your syntax of put and get commands is incomplete. just type put and press enter 2 times and ftp prompt will show you the correct syntax, do same for get command. Or simply google for their syntax. Also, for get you should have the file created in client directory, refer this