Module 3 milestone 2 connection refused ftp


how can i fix this error,anyone?

@skumar
I was able to reproduce this error by using the command ftp 0.0.0.0 8081 w/o starting the QBox server. Can you make sure you have the QBox server running in a different shell

Also, check in vsftpd_v1.conf if your ftp server is set to listen on port 8081

did everything ,still getting same error

it seems your server isn’t running please run it once


it is running in other terminal

It isn’t shown in the screenshot provided by you try this if the process shows if its running
image


it is showing this only,how do i run all other ?

your vsftpd spelling is wrong bro correct it first


did ,but getting same error

That means the server isn’t running on your machine

This proves that server is not running on your vm run it using sudo ./executable_file conf_file.conf and in other terminal try the same again

tried running this but getting this error
crio-user@souravkumar110098:~/workspace/QBox$ sudo ./vsftpd_v1 vsftpd_v1.conf
500 OOPS: config file not owned by correct user, or not a file

change the owner to root and try again

how can i change the owner to root?

By using ‘sudo chown’ command

crio-user@souravkumar110098:~/workspace/QBox$ sudo chown
chown: missing operand
Try ‘chown --help’ for more information.
getting this

use “sudo chown root file_name.conf” for changing the owner of the configuration file.


it was running but after that sudo command didn’t show any o/p

and running for server still getting same thing
crio-user@souravkumar110098:~/workspace/QBox$ ps -ef | grep vsftpd
crio-us+ 13567 13532 0 17:48 pts/2 00:00:00 grep --color=auto vsftpd

leave the server running on one terminal and in other terminal run that command you will find the process running