Module 2 Milestone no 4

I’ve been working on milestone 4 in module 2.
When i run the code in my terminal i get the expected result. But when i submit it i get error and the log files say, the following
“/aanand-d1998-ME_QBOX-f1631204-468f-11ea-945f-2954b29597c5/execution_dir/ /etc/os-release returncode > 0! Check your code.”
Can someone guide me?

Hey @Aanand returncode usually means exit code and in bash scripting language 0 means True and 1 and any other integer greater then 0 is known as False so just to summarise this error returncode==0 means your bash script execution is correct and it can leave with returncode 0 but if it is showing returncode > 0 then there is something wrong in your bash script like wrong syntax or wrong command

Happy Coding

But when i run it on my terminal, the result is correct :frowning:

there is lot of difference when you execute command in terminal and when you execute in form bash script you have to take care of bash scripting syntax and rules you should not forget shall or bash scripting is also a language you have to follow nomenclature of that language

1 Like

Will try to look into it sir. Thanks!