Module 2 - Milestone 4

What is the expected output for this milestone?
…Ubuntu…
…18…
or
…Ubuntu…
…18.0…
And does the difference matter in the assessment?

Yes It should only print the version number without any decimals

Any hint regarding this error - returncode>0!

It means that the program exited abnormally with an error code > 0
If a program exits with errorcode 0 then it means the program terminated successfully
else an error occured in the program which can arise from any point in the code

I am getting below two lines as output for module 2 milestone 4

OS is Ubuntu which is required for QBox
Ubuntu version is 18 which is sufficient for QBox

But in assessment, the test case fails for this

Same with me. Can’t understand why

I am Also getting the same error

i am also facing the same issue

same here . I am also getting the same error

same for me also now i dont know what to do?

Try to execute different command to get os information. The command you may be executing may not be installed on the testing server.

2 Likes

how to get two os one is ubuntu and other Ubuntu
for a same variable

how did you separate decimal i get 0! error

https://unix.stackexchange.com/questions/358801/grep-for-a-number-excluding-its-floating-point-part

Check this…Or google your question…Lots of resources available

Read the thing properly…check the conditionals used in the file.You’ll understand. :grin:

getting 0! error again i think error in finding particular row column. I uses awk command.Is it right or i need to use something else for finding particular row column.

You can use awk…But some related commands might not work during assessment(happened to me)

try converting the float to integer value.

Thanks. Exactly what happened with me too.
For everyone facing the problem try to use the etc/os-release file to fetch the informations.

1 Like

Me too.
Have you solved it?