Module 2 build failure message /proc/cpuinfo returncode > 0! Check your code

On running the script on I am getting this message on vm :CPU Speed of 2499 MHz is sufficient for QBox

but on submitting I am getting a build failure with a message:

2020-02-04 21:42:21,854 unitTesting INFO Assessing check_QBox_server_cpu.sh
2020-02-04 21:42:22,594 unitTesting ERROR /divyashahi139-ME_QBOX-36354160-4797-11ea-b4b0-4f890681b991/execution_dir/check_QBox_server_cpu.sh /proc/cpuinfo returncode > 0! Check your code.
2020-02-04 21:42:22,596 unitTesting INFO File: check_QBox_server_cpu.sh | Status: TEST_STATUS_FAILURE

may anyone explain what is the cause as I did every required thing but unable to understand this

use tail -1 ( piping ), that ensures you are picking one value to populate “cpuSpeedInMHz”
And I hope you have removed the decimal part properly.

I am also getting the same error. Did your problem got solved ?
I tried so many ways, but the build is failing every time.

avoid using bc ,instead use" tr "to extract , avoid using bc , for me it worked.Read about tr command and use that. and do required manipulation :slight_smile: