Module 1 Setup 2 Execution failed

I am getting following error when I do ./gradlew test --tests PortfolioManagerApplicationTest.testDebugValues
after substituting values of variables as asked in TODOS.

Could not create service of type DefaultGeneralCompileCaches using GradleScopeCompileServices.createGeneralCompileCaches()

Is your problem solved? I am facing the same error

Stopping all the active daemons and then trying the commands worked for me. Use ./gradlew --stop

You need to wait for the java things. As you can see in the bottom of your workspace.

Still getting following error.

erApplication.java:121: error: cannot find symbol
Thread.setDefaultUncaughtExceptionHandler(new UncaughtExceptionHandler());
^
symbol: class UncaughtExceptionHandler
location: class PortfolioManagerApplication
1 error

Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
Use ‘–warning-mode all’ to show the individual deprecation warnings.
See https://docs.gradle.org/5.2.1/userguide/command_line_interface.html#sec:command_line_warnings

Yes I have taken care of that.

No the problem still persists

Also when I reload workspace I get following error
Module TreeWalker initialization failed. It may be caused by wrong configuraiton or incompatible version

My problem was solved. Just wait for all the process to complete.

Reset workspace and wait for all the process to complete. Worked for me.

I have waited long enough still getting error

Resetting workspace and waiting for some time was the only thing i did and it worked