Module 1 Setup 2 Error

I am not able to start debugging. Error: No delegate commandhandler.

This link would help.

Reset your workspace and You need to wait for the java things. As you can see in the bottom of your workspace.

@sreejith @gouravsardana
I tried both. But i can’t type anything in the debug console.

Did you try placing the break point on line 47 instead of line 48 and then running the debug test?

Did you click the debug test. Also if you clicked run test it may not work.

yeah dude
I did the same. I went to test section, right clicked the mainReadFile and selected debug test. I cant type anything in the debug console.

Can u elaborate the steps that is used for this purpose?

i’ve got the same problem. Tried resetting the workspace a few times and waiting for all the java things to setup but that didn’t help.

I just now solved it. Try following the below steps,

  1. dont change anything in the
  2. Add a breakpoint in the return statement of the function “mainReadFile” in the
  3. add a breakpoint in the starting line of the “” to avoid debugging the test function.
  4. Go to TEST section which will be available on the left hand side.
  5. Expand the lists available in the test section. Finally you will see mainReadFile and testDebugValues.
  6. Right click on the mainReadFile and click debug test. the debugging will start. To verify the debugging is on process, u will see some navigation bar in the top of the file.
  7. open terminal and go to debug_console tab and type args[0]…
    and the steps will proceed as per the second TODOs in the java file.