Module 1 Milestone 3 Final Test Assessment

I am getting a returncode > 0 error
Following are the tricks I already tried/worked

  • Should work from any directory:My 4th milestone worked which has the same condition so it is not an issue as it passed
  • Force the program to returncode 0 - I tried it, worked in the crio workspace but failed the assessment
  • OR the command with a ‘true’ so the program always returns an exit code 0: Again failed in assessment but worked in crio workspace
  • The first time I ran this code it was successful in the assessment but could not complete as some other file was not passed. Copied the same file again but now is throwing an error.
    I used echo $? to know the returncode.
    Can a mentor please help me on this issue as I have been working on this for quite long

Hint: Don’t hardcode the path

1 Like

~/ is used not to hardcode the path which i have considered and the code is running on the workspace but the assessment keeps on failing

Just checkout this link you will find out the reason of returncode>0

1 Like