Modul3 setup is showing fatal: Could not read from remote repository

  1. Describe the issue briefly

  2. How much time have you spent debugging this issue?
    (Please spend at least 15 minutes to resolve the issue on your own before posting a new topic here)

  3. What is your hypothesis?
    crio-user@rkrjha1234:~/workspace/rkrjha1234-ME_QEATS_REVIEW_MP$
    crio-user@rkrjha1234:~/workspace/rkrjha1234-ME_QEATS_REVIEW_MP$ cd ~/workspace/rkrjha1234-ME_QEATS_REVIEW_MP/
    crio-user@rkrjha1234:~/workspace/rkrjha1234-ME_QEATS_REVIEW_MP$ git status
    On branch master
    Your branch is ahead of ‘origin/master’ by 2 commits.
    (use “git push” to publish your local commits)

nothing to commit, working tree clean
crio-user@rkrjha1234:~/workspace/rkrjha1234-ME_QEATS_REVIEW_MP$ git remote add ME_QEATS_REVIEW_MP_MODULE_PINTEREST_SHARE_STUB git@gitlab.crio.do:ME_QEATS_REVIEW_MP_STUBS/ME_QEATS_REVIEW_MP_MODULE_PINTEREST_SHARE_STUB.git
error: could not lock config file .git/config: File exists
fatal: could not set ‘remote.ME_QEATS_REVIEW_MP_MODULE_PINTEREST_SHARE_STUB.url’ to ‘git@gitlab.crio.do:ME_QEATS_REVIEW_MP_STUBS/ME_QEATS_REVIEW_MP_MODULE_PINTEREST_SHARE_STUB.git’
crio-user@rkrjha1234:~/workspace/rkrjha1234-ME_QEATS_REVIEW_MP$ git pull ME_QEATS_REVIEW_MP_MODULE_PINTEREST_SHARE_STUB master --allow-unrelated-histories
fatal: ‘ME_QEATS_REVIEW_MP_MODULE_PINTEREST_SHARE_STUB’ does not appear to be a git repository
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

crio-user@rkrjha1234:~/workspace/rkrjha1234-ME_QEATS_REVIEW_MP$

I am having the same issue while setting up the stub for 4th module!
Please help!

It’s because you are facing merege conflicts.
try to do – github reset --hard HEAD
and then again do --git status

and then commit the changes.

Even after ‘git reset --hard HEAD’ and ‘git commit’, it is showing me the same error.
If there were any merge conflicts then it was showing me that and i resolved it but in this case the error is different.
error: could not lock config file .git/config: File exists
fatal: could not set ‘remote.ME_QEATS_REVIEW_MP_MODULE_TAG_SUGGESTION_STUB.url’ to ‘git@gitlab.crio.do:ME_QEATS_REVIEW_MP_STUBS/ME_QEATS_REVIEW_MP_MODULE_TAG_SUGGESTION_STUB.git’

you missed one command i guess.

git remote add ME_QEATS_REVIEW_MP_MODULE_TAG_SUGGESTION_STUB git@gitlab.crio.do:ME_QEATS_REVIEW_MP_STUBS/ME_QEATS_REVIEW_MP_MODULE_TAG_SUGGESTION_STUB.git

git pull ME_QEATS_REVIEW_MP_MODULE_TAG_SUGGESTION_STUB master --allow-unrelated-histories

I have fired both the commands.

It should have worked for you

Do I need to set up any Stub URL manually?

Please refer this question.