Milestone 3:config params


testcase failed for this. Tried many times,still failed. I have added the two flags which were required in the file. any help?

Why don’t you try checking whether you get same file permissions for all versions after those flags and getting different without those flag?

hint: please refer the manual for vsftpd, are you adding correct flags, is 2 flags sufficient?

getting same after using them and different without using them.

you using different files everytime right?

yes…without the flag i m getting different permission from the benchmark version only for the faulty one…and after using the flags getting the correct permission for the faulty one also

do check all versions after adding all flags,not just the faulty one,maybe they changed because of flags

do i need to write the value after the keys added in the config params file?

yes, in the file you have to mention what flag you added along with the respective values.

you mean there are more than 2 parameters

thats your part of fun to figure out that do you need more flags or not or there are already more flags, refer manual of vsftpd for any reference

thanks…but i tried both the ways and it again failed.

there must be something wrong with your flags, figure it out, i can assure you this is the simplest milestone of module 4, its very straight forward.

1 Like

You have to write these flags in a different file also as mentioned in the task. Are you doing this?

yes ofcourse i m doing that

@Kiran please have a look !

and what about the versions that just won’t run?

Hey some versions are faulty. Isn’t it what we are checking in this task?
And i believe there is a milestone for incorrect file transfers.

thanks, thats cool

i just wanted to understand as to how those versions will be treated in the “file permissions” milestone.

You have got the filename wrong, you are using config_params_to_correct_file_permission instead of config_params_to_correct_file_permissions
The “s” is missing at the end of the filename.