Mark as Complete Not working

Mark as complete button does not respond and I am not able to proceed to the next task.

Log Out, flush cache of browser,log IN

By cache you mean the cookies or the browser history.

Everything you can possibly remove. Better do a Hard Reset ctrl+shift+r

Same here module 4 is still locked .

I solved the problem. Actually I am a Mac user and use Safari browser. Looks like there is some issue with it. Also in the docs it was mentioned that crio works best on google chrome.
So use chrome.

I am using chrome on mac. Tried everything like command+shift+r, logging out and in still doesnt unlock the module. Which module are you in btw?

I have just started so I am in module 1. And chrome is working fine for me.

Are you able to Login?

Yeah login works fine

Is your Internet Slow? Try restarting the PC. I don’t know, others aren’t facing the problem now, so I think it must be from your end!

Stop any downloads if any going on

Module 4 is closed I guess. You will have to wait for the announcement that module 4 is open.