Killed wrong process

Due to an interrupt (by mistake), the vsftpd_v4 was killed by me (Ctrl+Z). So, to destroy it I used kill -9 <pid>.

But by mistake, instead of giving the pid of vsftpd_v4, I gave pid of some random process. This happened because the htop window was small and in hurry I killed another process (I don’t know which one).

But the result was this(in the image above), the NI column has many -20 for many new processes which were not there before.

And because of this, I think many of the commands are misbehaving, and I’m not able to pass the incorrect_file_permission.

I logged out of the workspace and again logged in, but in vain, the htop is showing similar result.

Please help me in fixing this issue.

Did you reset your workspace? @deepamgupta

Please tell how to do that, should I run the setup once again?
But I think this will delete all of my work till now, and I am on the verge to finish module 4.

In the workspace, at the top right there’s a button called reset workspace. It won’t affect any files stored in the workspace directory. @deepamgupta


I can’t see any Reset Workspace button here, is it anywhere else?

@deepamgupta But mine has it.

Perform a hard refresh. See if the reset workspace button appears. Otherwise contact Crio Devs for help

Hey perform hard refresh (Ctrl + shift +r). Then use htop with filters. Don’t use it without filter it will be very difficult for you to locate processes and note change.
Hint: watch this https://youtu.be/Qw2ZUf0hTF8

No, the reset workspace button did not appear even after hard refresh and opening in Incognito mode also.

Just perform a hard refresh and start from the beginning for vsftpd_v4

Don’t worry about the reset workshop button it might be a system issue (contact Crio team about that) for now just perform hard reset(ctrl+shift+R) and see if everything is working properly use htop to see all the processes and continue the module.

The problem solved automatically, when I restarted the session in the morning.