Issues submitting the commit

I get the following issue while submitting Module 3:

Hi @irfan
Looks like you are facing challenges in the current module.

Below is a link to all the FAQ’s for the current module

Below are a few similar topics raised by other users which you might find usefull

Note - This is a BETA Feature,if you find this helpful, kindly let us know.
Feedback link - https://forms.gle/cmxN5pdTXgnwgC986

Kindly mark this as a solution if this has helped you solve your query

Hi Irfan,

Were you able to sort it out?

not yet, I tried couple of things but didn’t work and issue is same…

Ok,
So let’s try walking through the error together

  1. remote: The project you were looking for could not be found
  2. fatal: could not read from remote repository
  3. Please make sure you have the correct access rights and the repository exists

Any thoughts on possible issues these messages are pointing to?

Present log file & the folder permissions are
image

and I tried this, I could be wrong…
image

should I try super user? which is kind of dumb question though… :slight_smile:

Ok, good thinking the reason may be because of the workspace access issues as the vsftpd.log file is being owned by the root user.

But, as we are having trouble when working with git push it will be safe to assume the issue is regarding Git repo itself.

So let’s check if you have access to the repo you are doing git push to.The command being used is git push -u origin master which means you are trying to push to a remote repo named origin. Can you find out which repo origin points to in your workspace using git remote -v

And once you get the SSH link from the git remote -v command of the repo origin points to, try out if you can make a normal URL out of it, and access it using your browser

2 Likes

I get the following when I try, git remote -v, previously I was able to see the list… but not right now… strange…
image

Please try it once again from your ME directory. irfan-arshad4-me_qbox

1 Like

Perfect I see that now, should I try username@…

Cool, you can try visiting the link pointed by origin by changing the SSH link eg: git@gitlab.crio.do:COHORT_ME_QBOX_ENROLL_CRIO_LAUNCH_2020/nabhu123-ME_QBOX.git

to a normal URL

gitlab.crio.do/COHORT_ME_QBOX_ENROLL_CRIO_LAUNCH_2020/nabhu123-ME_QBOX.git

1 Like

or like this? https://crio-user@gitlab.crio.do:COHORT_ME_QBOX_ENROLL_DEVSPRINT_1105/irfan-arshad4-ME_QBOX.git

I am able to reach the URL.

If you are able to see your project content in Gitlab, that would mean you have access to the repo.

Can you try running the setup instructions again?

  • First, copy your latest updates (Module 3) files, eg: server_connections, vsftpd.log etc that will be required for assessment to the ~/workspace directory to avoid losing it

  • Then, execute git remote remove ME_QBOX_MODULE_CLIENT_SERVER_STUB to remove the remote from your git remote list

  • Then, execute instructions in Setup #1: Get the source stubs for this module

It gives 404 error, when I try to access… looks like system issue, I tried a lot of different things with TA@ved, does not seem to work, if someone can reach out me would be great…

Hey @irfan looks like you had left your QBox project on gitlab, I have added you back , can you check now ?
You must be able to push the changes

yep, starting now from scratch… mod3

Closing this topic as your issue is resolved by the mentor. If it is still not resolved, Kindly un-mark the accepted solution or create a new topic and post this question as a reference link in the description of the new topic.