Io.spring.dependency-management not found

Can someone explain me why am I getting this error.

Could not run phased build action using Gradle distribution ‘https://services.gradle.org/distributions/gradle-5.4-bin.zip’.
Build file ‘/home/crio-user/workspace/gauravrmsc-ME_QMONEY/qmoney/build.gradle’ line: 2
Plugin [id: ‘io.spring.dependency-management’] was not found in any of the following sources:

  • Gradle Core Plugins (plugin is not in ‘org.gradle’ namespace)
  • Plugin Repositories (plugin dependency must include a version number for this source)
    Plugin [id: ‘io.spring.dependency-management’] was not found in any of the following sources:
  • Gradle Core Plugins (plugin is not in ‘org.gradle’ namespace)
  • Plugin Repositories (plugin dependency must include a version number for this source)

Which command are you running? gradle or ./gradlew ?

is your workspace loaded fully before running ./gradlew build?

@anand-crio
I am facing the same problem, how to fix it?

which directory are you running the build? You need to run it inside your root directory.