InvalidDefinitionException in assessment

Getting this error on both hidden test cases:

com.crio.qeats.controller.RestaurantControllerDebugModuleHiddenTest1 > hiddenTest2() FAILED     com.fasterxml.jackson.databind.exc.InvalidDefinitionException at RestaurantControllerDebugModuleHiddenTest1.java:135

Both the android app and build is working fine. I am getting expected resposes, other tests pass and the android app doesn’t crash.

Hi,
Please refer these discussion and see if they help


No args constructor fixed it. But it wasn’t required for the actual code or tests, how can hidden test cases expect us to declare it ? Anyways, now I am getting:
first passed.
AND

    org.opentest4j.AssertionFailedError at RestaurantControllerDebugModuleHiddenTest1.java:127

There can be several ways to handle the bug - removing invalid objects, change encoding, replace some chars etc. How am I supposed to know which one you’re expecting ?

EDIT: It got solved after I moved it from service layer to controller layer. well, I was doing it in service layer not repo layer, it shouldn’t fail I guess.

Closing this topic as your issue is resolved by the mentor. If it is still not resolved, Kindly un-mark the accepted solution or create a new topic and post this question as a reference link in the description of the new topic.