Import java.net.http.HttpHeaders; not getting resolved

when I run ./gradlew build, it shows me this error. How can I resolve this?

@Nabhan-CrioTA, can you help me out here?

Hey there,
Could be the package is different with different jdk versions. Found a different import

import org.springframework.http.HttpHeaders; 

Ref 1 2

Seems like java.net.http was introduced in JDK 11

oh, cool. this works. Also, I wanted to know if we have to use some specific java version for this project?. And if the default import which was mentioned in the stubs i.e (import java.net.http.HttpHeaders;) is for Java 11, does it mean that we can go ahead with Java 11?.

Closing this topic as your issue is resolved by the mentor. If it is still not resolved, Kindly un-mark the accepted solution or create a new topic and post this question as a reference link in the description of the new topic.

Ok, then it should work on assessments as well.