Import error of packages

I get error: package com.crio.warmup.stock.dto does not exist error when I run the portofilo file?
how to resolve this?

You are importing wrong thing.
It should be dto.something
dto is not a package.

I’m imprting this: import com.crio.warmup.stock.dto.AnnualizedReturn; (Its already written in the file , I havent written this).

And I get this error in terminal : PortfolioManagerApplication.java:5: error: package com.crio.warmup.stock.dto does not exist
import com.crio.warmup.stock.dto.AnnualizedReturn;

Whats wrong in the above lines?

Did you try this Package import error

I moved the package line in each java file to line 1, but still showing same error. @sreejith

I want to check mainReadFile() , so I’m running javac PortfolioManagerApplication.java and I get these import errors.

Take a look at this and try building using the gradlew args command given in todo and dont use javac

I am not sure if it will work but this link will help you for future milestone

Suppose I’ve written System.print.ln(“Hello”) in mainReadFile() , and I want to print this “Hello” into terminal. How to do this?

Is the issue resolved ? If not then use ./gradlew clean :slight_smile: