I am getting error in the test file ,I am only working with portfoliomanagerapplication.java.how can I resolve this.p.s-Ive tried hard reset and repulling but end up with same problem

@yash_bhole

Hey can you please make sure you have resolved your merge conflicts properly and click on PROBLEMS tab and see what are those errors and try to rectify them related to PortfolioManagerApplication.java.

done that number of times…accepted all incoming changes.Mergetool status-no merge conflicts

Seems like there are errors in your imports. Please do a hard refresh wait for the for workspace to load the dependencies. Also try doing a ./gradlew clean

done it
still same
the strange thing is that when I’m running my code using gradles in todos and gradle in the documentation its showing ‘build successful’ but on the contrary its not commited + test file is red which it should not be

You mean to say that you have performed all the tasks related to this module. And when you did a ./gradlew build it shows success. But there are errors in the test file.

// ./gradlew run --args=“trades.json 2020-01-01”

// ./gradlew run --args=“trades.json 2019-07-01”

// ./gradlew run --args=“trades.json 2019-12-03”

these in todos

./gradlew run --args=‘trades.json 2020-01-01’

taskboard milestone #3

all are successful

i ran gradle --stacktrace

  • Where:
    Build file ‘/home/crio-user/workspace/yashbhole6-ME_QMONEY/build.gradle’ line: 32

  • What went wrong:
    A problem occurred evaluating root project ‘ME_QMONEY_MODULE_CALCULATIONS’.

Failed to apply plugin [id ‘com.github.spotbugs’]
Gradle version Gradle 4.4.1 is unsupported. Please use Gradle 5.0 or later.

Hey,

Can you please confirm - Did you modify your gradle file or run any command ?

no i did not, i just used its debugger (in terminal) for checkset errors

Hey,
As i can see in your gitlab history you copied the code from some other user. As i can see your name is yash and in the debug output it is rajesh. It might be the case you copied paste some other code and you messed up with gradle or some other file. So, Its better to go back to your previous module and start it with your own implementation :slight_smile:

To go back to your previous module refer to this -

Closing this topic as there is no response since last 12 hours. Please feel free to create a new topic and post this question as a reference link in the description of the new topic.