How to install vsftpd and start the server?

I entered the following command vsftpd_v1 vsftpd_v1.conf and it says vsftpd_v1: command not found. So do we need to install vsftpd using yum command as it is mentioned that DO NOT install vsftpd using apt-get . Please tell what do do next ?.

No, You don’t need to install anything. You will have to follow the instructions and debug it.

You are on the right track. Figure it out !

Okay, working on it,Thanks !

As a next step, I added listen_port=8081 in the .conf file. and tried to give permission using chmod +x vsftpd_v1.conf . But it says chmod: cannot access ‘vsftpd_v1.conf’: No such file or directory.

You can use Sudo before

cannot access ‘vsftpd_v1.conf’: No such file or directory. Also i can’t see vsftpd file in ls -l command results. How to get that ?

You are in the wrong direction. Its in the QBox directory.

You are on the right track. Figure it out what to do? What to add on? How to run the config file?

Exec format error while running the file vsftpd_v1 for the command " ./vsftpd_v1 vsftpd_v1.conf"

so i tried running binary file using .bin but it results into :
./vsftpd_v1.bin: No such file or directory

Don’t use .bin. Read the error and debug it.

But i can see that vsftpd_v1 has execution permission as shown in the attachment

please follow the step(if executed as it is, you should be able to run the server):

  1. give execute permission only to vsftpd_v1 using chmod
  2. then run the vsftpd_v1 using root but dont include .conf file

Working on it. Thanks !

1 Like

Did this exact thing and it seems to be listening but when I run netstat -an on another terminal, i cant find vsftpd to find its port number. How do i counter this?

after giving netstat -an command, look for 0.0.0.0:8081
or in case if you haven’t changed the port yet, then you will see something like 0.0.0.0:21
But you won’t see the name. and you can also verify if the process is actually running or not by ps -ef

Got it! Thanks a lot!!. Why is it essential to change the port number. I dont think it’s a compulsion.

because 21 is default port, so its also vulnerable, for security reason we should change the port.

Oh…okay. I added listen_port=8081 to the .conf file but i cant see 0.0.0.0:8081 when i execute netstat -an. What might be the cause?

after modifying the conf file, you have to restart the vsftpd server again.