Getting a 400 response from clarifai api

  1. Describe the issue briefly
    I am getting a 400 response from clarifai api. I have tried everything from changing header format to trying the curl command given in the docs. Nothing is working.
  2. How much time have you spent debugging this issue?
    (Please spend at least 15 minutes to resolve the issue on your own before posting a new topic here)
    2 hrs
  3. What is your hypothesis?
    I feel that I may be missing something important, but do not know what exactly I am missing.

Hey Animesh, Have you tried posting to the api using postman?

Yes. Not able to run it there as well. I’ve tried changing header formats lots of times. But no luck

I have been using ‘Auth’: Key whatever_api_key in header. Is this the wrong format?

Can you please read about the following. I’m sure you’ll figure it out:
Importing curl commands into postman and exporting codes from postman.

Thank you. I have gone through it. The problem is that the authorization is not happening in the Postman service as well

Is your issue solved because I’m getting the same error regarding authorization 401

Solution:
Format your request properly using postman.
Check the authorization field and body fields properly.

Not able to authorize.Getting same error ,error 400.