Get command not working error 500 , can't open file

I tried transfering file from crio ftp_client using passive mode but get command but failed
get download.txt
I am getting here file can’t be opened failed 500
I even tried
on giving entire command directory was not found
than giving
ftp> get ~/workspace/ftp_server/download.txt
local: /home/crio-user/workspace/ftp_server/download.txt remote: ~/workspace/ftp_server/download.txt
local: /home/crio-user/workspace/ftp_server/download.txt: Operation not permitted
ftp> sudo get ~/workspace/ftp_server/download.txt

after that I even checked permission of files and tried given all permission to the files found out everything on the forum as well as net , than I got to know this warning can be ignored but I am not sure, how to deal with it , please help

Hey this worked for me after the put command:

ftp> get ~/workspace/ftp_server/download.txt

Try again and check.

Check for file permissions and make sure you have not defined unwanted parameters into vsftpd.conf file and read and follow instructions carefully.