Ftp server connection refused

I have successfully setup the vsftpd server but when i am trying run it i am facing this error.
Please guys help me i am stuck at it from yesterday.

@sammynerd what’s the error?

ftp connection refused, when i am giving command
ftp -p my_workspace_IP 8081

Is your qbox server running?


i think it is running

Instead of my_workspace_Ip use localhost 0.0.0.0

still it is giving connection refused

You have to run both vsftp and vsftp.conf file as mentioned in the module.

You have to run vsftp.conf file along with vsftp.

thanks for telling this @divyanshu
no it is showing connect but getting this error, can you tell why it is

I know the solution @sammynerd but can’t tell you straight away, try googling.

@divyanshu i think i have to make changes in vsftpd.conf file but don’t know what to modify

Yes you are getting close.

now after change it to NO i am getting this error
500 OOPS: vsftpd: both local and anonymous access disabled!

getting same error pls help me out with this

Anonymous mode needs to be disabled in the config file to resolve this error. Also, enable the option to write to filesystem and option to allow local logins.

Make sure there are no duplicate configuration entries in the config file.

ok thanks i have searched but i don’t get the code for doing this
i tried adding this

userlist_enable=YES
userlist_file=anonymous
1 Like

Does this solves your issue?

no it didn’t solved the issue

anonymous_enable
Controls whether anonymous logins are permitted or not. If enabled, both the usernames ftp and anonymous are recognised as anonymous logins.

ftp_username
This is the name of the user we use for handling anonymous FTP. The home directory of this user is the root of the anonymous FTP area.

For more info: See this