Ftp Login Failed

Please disable Anonymous mode. Refer Error: "vsftpd can not locate users specified in ‘ftp_username’ :ftp" or "vsftpd: both local and anonymous access disabled"
If you still see the error, could you check if your password contains any special characters, like $ ?

I’ve tried almost all the above mentioned changes but it didn’t work for me.
My password does contain a $.

I’ve made anonymous mode off and also enabled writing files and local logins. but still getting same error . My password doesn’t contain $ but contains #.

I tried everything but the password doesnt work, both for sudo and ftp. I have the same problem described in this thread.

Passwords with $ may cause a problem. We’ll check on this.

Yah … my password also contains dollar

My password does contain @

1 Like

I too am facing the same issue,applied all the changes , no $ in password it contains -._

tried this but not working . i do have a $ in my password

did all the suggested changes in configuration file to anonymous mode, writing any file and local user. and using alpha-numeric password (only characters and numbers). but still having same issue!

1 Like

One way to confirm if it is a password issue is this. See if you can do su - crio-user and enter the password given to login as crio-user into the shell. If this works, then password is not an issue. It has to be the config parameters.

Should look like this if its not a password issue:
crio-user@kiransuresh2020:~$ su - crio-user
Password:
crio-user@kiransuresh2020:~$

1 Like

If it is not a password issue, set run_as_launching_user=NO and keep connect_from_port_20=YES
Keep anonymous mode switched off.

5 Likes

Authentication failure when I do the steps you said. Please help

I guess password is the issue in my case.

can you please post your error here

yes, Please check your password

It’s been a day now facing this wrong password error, I’ve tried everything but nothing seems to be working. (There’s a ‘$’ in my password)


Wrong Password ;(

please read all the answer by kiran (crio - team ) in this topic. this is the same issue that has been resolved in this topic.

Screenshot from 2020-02-02 10-43-34

When I set “run_as_launching_user=NO”

4 Likes