Ftp Login Failed

image

Logs generated by vsftpd server

Login Failed, when tried to login using crio-user credentials.
My vsftpd_v1 server is running. when i try to connect to the server through ftp it makes an entry into log file.

ISSUE : i think vsftpd server didn’t able to find or read allowed user list (i.e. the local users). as with my previous configurations it works fine with anonymous user. so there will be no such error in connection between ftp and vsftpd.

Hey, Can you please Check your vsftpd config file , and look for the respective Port Number.
It’s probable that the port you’re trying to access in the FTP and the config file do not match.

what password we need to use for crio-user?Please help.

If we use different Port Number then there will be no response from server. Here the log file shows the server reponse to the ftp connection request.

I am also facing same login problem ----421 Service not available, remote server has closed connection. Port I’m using in command and in vsftpd configuration file are same(8081).

1 Like

hey , please if anyone has found solution then post here … this has been hours , this problem has not been resolved for me

@ajay-crio @Rahul-Crio.do @Sakshat-Crio.Do @Rohin_Crio-Tech sir please help. stuck here for a long time.

Can you authenticate while using sudo using the same password ?
If so then maybe you could try to change the password temporarily and try with an easier password so that the chance of making a mistake is less.

I copied the password without any extra space.

I don’t think copying the password works while using ftp
At least it didn’t work for me

We are working on it

4 Likes

Use the workspace password

But it is still showing login failed

Hi can you try to login anonymously ?
use username as “ftp” and no password that will try to login anonymously

It works but not with crio-user

you are not supposed to allow the server to login anonymously…

Yes I know but I just wanted to see whether the login can be done using anonymous

Also @ssndhu01 can you try to set the flag local_enable to YES in the configuration file and try again

already using same value for local_enable and working correctly with anonymous user

Do you have a local linux machine? If you do then maybe try to scp the file onto your local machine and try to run it in your local environment .

Facing Same issue.
Is this something being fixed from your end @ Crio Team ?