Ftp error 550 Failed to open file

I am trying to make the transfer of a file but it is saying the file could not be opened, although my server is running, the file is present in ftp_server, and everything else is also correct. Stuck on this error for 2 days. tried every possible solution I found on google, stackoverflow etc

Are you specifying the path from where are you getting the smallfile.txt ? I can see you are currently in ftp_client directory and you are trying to get smallfile.txt but from where.

after changing pwd or lcd, go to specific directory where you want to perform put or get command.

So I started ftp from ~/ftp_server and inside ftp i changed directory to ~/ftp_client. my files are in ftp_server. here i ran get command, and now i’m getting some permission issues

how to specify the path?

give permission to your file by chmod command.
Try 755 and if it not work then go for 777 permission

did but issue is still there

check your vsftpd.conf file’s rule of written, local and anno

yes its written over there but issue not resolved

Can you see the below forum topic for reference.

Check Current Directory and work accordingly

no profit still the error is there, also attended office hours for module 4 yesterday but none of the solutions helped out

How are you creating the file? Try dd command instead of fallocate.

I found the solution, my directories of ftp_server and ftp_client were owned by root, I changed owner to crio-user