Ftp : connection timed out

I am getting this error :

ftp> cd ~/workspace/ftp_server
250 Directory successfully changed.
ftp> put ~/workspace/ftp_client/upload.txt
local: /home/crio-user/workspace/ftp_client/upload.txt remote: /home/crio-user/workspace/ftp_client/upload.txt
500 Illegal PORT command.
ftp: bind: Address already in use
ftp> pass
Passive mode on.
ftp> put ~/workspace/ftp_client/upload.txt
local: /home/crio-user/workspace/ftp_client/upload.txt remote: /home/crio-user/workspace/ftp_client/upload.txt
227 Entering Passive Mode (3,6,164,108,4,99).
ftp: connect: Connection timed out

while changing to this :

ftp_username=crio-user
pasv_enable=YES
pasv_promiscuous=YES
pasv_max_port=2000
pasv_min_port=1025
pasv_address=3.6.164.108

I have checked and 8081 port is being used and all other vsftpd_v1 processes are killed

You don’t need promiscuous parameter to be set.
Please Check if there are any duplicate entries any of the parameters.

Already resolved. thanks

How did you Resolve the error? I’m stuck at it.

Check for the vsftpd.conf file and see if you need to change any boolean values.

Yes, found it, had to change a yes to no