FTP : 500 OOPS: vsftpd: cannot locate user specified in 'ftp_username':ftp

Although there are other similar questions in the forum. I tried following them and i’m getting this error. If anybody did solve this issue please help.
All the permissions are shown the pics. I have also created the empty directory as mentioned in other answers. Still its not working.

In the vsftpd.conf file write :
ftp_username=crio-user
you may remove the run_as_launching_user=NO

let me know, if that works .


Tried it, but im getting login failed now

make sure the server is up and running. If even that does not work …add an extra feild
listen=YES into the vsftpd.conf file. And then run the server. And then run the ftp command

500 OOPS: vsftpd: not found: directory given in ‘secure_chroot_dir’:/usr/share/empty
I am getting above specified error when I am trying to connect by command : ftp 0.0.0.0 8081
Any Idea about this?

Open a new terminal and create a dummy directory specified in the error


What should the Name be ?

set anonynmous_enable to NO and make sure configuration is effective after you have modified vsftpd.conf. It’s of no use if you are modifying config and if at all changes are not reflecting. You may have to kill the vsftdpd_v1 and start the whole procedure again. ftp connection will work.
And if you are in task 2 change directory to ftp_client

3 Likes

man its obvious …your ftp_username.

crio-user…

1 Like

Yup! It worked. Thanks


Getting this error now !

Could someone please upload crt vsftp_v1.conf file, can compare with mine is its correct or not !
Thanks

set local__enable to yes…And understanding these errors are important. btw we cant upload conf file which violates Crio.Do rules. Search those errors and try to understand what do they mean. Maybe it will help you in further modules too. I know its frustrating, even I faced lot of errors. It happens. Happy learning go ahead :slightly_smiling_face:

Opps sorry!
Thanks anyway for helping me till here :+1::blush:
Will try to figure out on my own

1 Like

if you continue getting errors and unable to solve after spending enough time on it. never mind put em here or rise a new ticket. It helps others too.

Woah…thankyou everyone @AmoghaKS @surya12 @swaroop2200 This was helpful !

2 Likes

Welcome bro :slight_smile: Happy to help.


I tried everything mentioned in this thread and others but I am unable to overcome this error for past 12+ hours may please suggest what could be done, also I am not getting created .log files in this directory isn’t that a cause of this error please help
@AmoghaKS @swaroop2200 @surya12

You should specify username as well in the vsftpd_v1.conf file. As I have suggested above.

1 Like